Linux dính lỗi bảo mật “ngớ ngẩn” khiến máy tính bị xâm nhập dễ dàng

Một lỗi bảo mật vừa được phát hiện trên hệ điều hành Linux khiến những thiết bị sử dụng hệ điều hành này có thể dễ dàng bị xâm nhập chỉ bằng cách nhấn xóa (backspace) trên bàn phím.

Cụ thể, nếu người dùng nhấn nút backspace 28 lần liên tục sẽ truy cập được vào máy tính chạy hệ điều hành Linux đang ở chế độ khóa. Lỗ hổng bảo mật này được hai chuyên gia Hector Marco và Ismael Ripoll của Phòng nghiên cứu an ninh mạng Đại học Bách khoa Valencia phát hiện ra. Đây là lỗ hổng bảo mật nằm trên bộ nạp khởi động GRUB được sử dụng trên hầu hết các phiên bản của hệ điều hành Linux, bao gồm các hệ điều hành phổ biến như Ubuntu, Red Hat, Debian…

Linux dính lỗi bảo mật “ngớ ngẩn” khiến máy tính bị xâm nhập dễ dàng.

Linux dính lỗi bảo mật “ngớ ngẩn” khiến máy tính bị xâm nhập dễ dàng.

Theo hai chuyên gia bảo mật này, bộ nạp khởi động (bootloader) được sử dụng để khởi động hệ thống Linux và sử dụng một hệ thống quản lý mật khẩu để bảo vệ quá trình khởi động, không chỉ ngăn chặn những sự xâm nhập trái phép và còn vô hiệu hóa các thiết bị ngoại vi như CD-ROM và các cổng USB. Nếu không có hệ thống bảo vệ của GRUB, tin tặc có thể khởi động hệ thống trực tiếp từ USB để truy cập trái phép dữ liệu có trên ổ cứng máy tính.

Lỗ hổng bảo mật ảnh hưởng trên phiên bản GRUB2 từ 1.98 đến 2.02, nghĩa là các phiên bản được phát hành từ năm 2009 đến nay, khiến lỗ hổng bảo mật này nghiêm trọng có ảnh hưởng trên diện rộng.

Với những người dùng đang sử dụng máy tính chạy Linux để kiểm tra xem máy tính của mình có bị ảnh hưởng bởi lỗ hổng bảo mật này hay không khá đơn giản. Khi khởi động máy tính và xuất hiện giao diện yêu cầu người dùng điền tên sử dụng và mật khẩu để đăng nhập, người dùng chỉ việc nhấn nút backspace 28 lần. Nếu phiên bản Linux bị ảnh hưởng bởi lỗ hổng bảo mật, hệ thống sẽ tự khởi động lại và truy cập vào hệ thống hoặc sẽ xuất hiện giao diện shell của Grub.

Giao diện shell (điều khiển bằng câu lệnh) này sẽ cung cấp đày đủ đặc quyền để truy cập vào các chức năng trên hệ thống, cài đặt thêm các phần mềm độc hại, truy cập dữ liệu hoặc phá hủy toàn bộ dữ liệu có trên thiết bị.

Như vậy có thể thấy lỗ hổng bảo mật này không chỉ giúp người khác xâm nhập trái phép vào máy tính chạy Linux để đánh cắp dữ liệu mà còn có thể cài đặt thêm các phần mềm độc hại lên máy tính để âm thầm theo dõi người dùng về sau.

Tuy nhiên, điều may mắn là để khai thác lỗ hổng bảo mật này đòi hỏi các tin tặc phải có sự tiếp cận trực tiếp với máy tính chứ không thể tấn công từ xa, do vậy đã hạn chế phần nào mức độ nguy hiểm của lỗi bảo mật.

Hiện tại đã có một bản vá khẩn cấp do hãng phần mềm Github phát triển cho người dùng Linux, tuy nhiên hiện các hãng phần mềm lớn đứng sau các phiên bản Linux vẫn chưa phát hành bản vá cho các sản phẩm của mình. Các chuyên gia bảo mật khuyến cáo người dùng nên nâng cấp nhanh chóng máy tính của mình ngay khi bản vá lỗi được phát hành.

T.Thủy (Dân Trí)

 

Trả lời

Thư điện tử của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *